• Specific new YouTube bug on seemingly random videos


    • Fixed Assigned: Katie

    So far there appears to be three kinds of videos on YouTube:

    • Case #1: Videos that play properly
    • Case #2: Videos that only display the thumbnail (no video/audio, just a still of the thumbnail), but metadata is received okay.
    • Case #3: Videos that display a blank, black screen, but metadata is received okay.


    This third case is what this bug report is about.

     

    The behavior is:

    Video starts, metadata (title, thumb, length, etc) are all accurate but the screen is black and no audio heard. This I've tested myself and is universally observed for the same URLs regardless of person (player) watching.

     

    Example URL: http://www.youtube.com/watch?v=_Tot57oG7-U

     

    Upon using playx_debug 1 for inspection, there are two console errors specific to Case #3 (this bug) that do not occur in cases #1 or #2:

    PlayX DEBUG: Couldn't find decipher function, try again?
    PlayX DEBUG: No WebM found, falling back to JW.
    http://gcinema.xerasin.com/playvideo.php?vid=_Tot57oG7-U&t=0&vol=28

    These two debug messages (followed by the video handler URL mention) are unique to Case #3.

    It appears to be an Awesomium problem at first glance, due to my Chromium browser having no problem opening up that URL (http://gcinema.xerasin.com/playvideo.php?vid=_Tot57oG7-U&t=0&vol=28) and it playing, but that same URL is a blank dead screen in Cinema. Setting that specific URL as my Welcome Screen to test also resulted in the same problem, dead screen with no video or audio. Therefore it appears that this bug is a bug in that playvideo.php script, or specifically, its behavior in Awesomium (or PlayX?).

     

    The most odd thing about this problem is that there seems to be no rhyme or reason for which YouTube videos this occurs with. Age of the video (post date) appears to have no bearing on its occurrence (thus ruling out some kind of "processing delay").



    User Feedback

    Recommended Comments



    Please sign in to comment

    You will be able to leave a comment after signing in



    Sign In Now

  • Status Definitions

    Open = This report has been recently created. It hasn't been assigned yet.

    Pending = We are working on this report.

    Fixed = The issue has been fixed and the resolution will be available in the next version.

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.